10.7.5: encrypting a text file

Sam's Avatar

Sam

25 May, 2013 09:26 PM

Using GPGtools downloaded from - https://gpgtools.org/

Hey,

I'm having trouble encrypting a regular text file so I can copy and paste the encrypted version into a message.

So, I type my message into textedit. Save the file, then control click --> services --> encrypt file (then select the public key of my recipient). However, this creates a zip file that can only be opened to view the unencrypted version. I want to copy and paste the encrypted data as I am using a forum and not sending an email (I can't attach files).

How do I solve this problem? The other forum topics I've read where this issue has been raised have not been answered.

Please, a step-by-step answer would be greatly appreciated.

Thanks,
Sam

  1. Support Staff 2 Posted by Steve on 27 May, 2013 10:16 AM

    Steve's Avatar

    Hi Sam,

    could you send me a links to the unanswered discussions? We are trying to avoid closing unanswered questions so that either is a "no user feedback" or a mistake.

    As for your question: from what you write you seem to be encrypting the text file. But you want to encrypt the text itself (not the file).

    To encrypt the text

    • open text edit
    • write or paste your text
    • mark everything
    • right-click
    • Services > OpenPGP: Encrypt Selection
    • Choose your options in the GPGServices window
    • see the encrypted msg
    • copy & paste that to wherever

    Does this answer your question?

    Best, steve

  2. 3 Posted by Sam on 28 May, 2013 12:51 AM

    Sam's Avatar

    Hey,

    Well, no. That's doesn't work. However, I did resolve the issue.

    Maybe it's because of my version of OS, but you can't select text in textedit to encrypt. You can only encrypt the whole file. The "services" option won't come up from within text edit when I right click highlighted text.

    In order to encrypt specific text I have to open apple mail, type what I want in an email, and then select text and choose "encrypt in new window". From there everything works as it should.

    Sure, here's one of the first threads that comes up in Google when I type "gpgtools encrypting text".

    http://support.gpgtools.org/discussions/everything/1569-how-to-encrypt-text-only-messages-not-email

    Best,
    Sam

    P.S. I found this youtube video which answered my question - http://www.youtube.com/watch?v=yXm0dtYFxZk

  3. Support Staff 4 Posted by Steve on 28 May, 2013 09:33 AM

    Steve's Avatar

    Sam, glad you are now setup up. We've had another user who lacked that right-click Services menu. I'm not sure what's up with that, we'll have to investigate.

    But there's another simply way to get this done with GPGServices. Could you please

    • open TextEdit
    • Type test
    • cmd + a (to select the text)
    • go to MenuBar "TextEdit" at the top right of your screen
    • Services > OpenPGP: Encrypt Selection

    Does this work for you?

  4. 5 Posted by Sam on 28 May, 2013 08:06 PM

    Sam's Avatar

    Hey Steve,

    Yeah, I found it weird too because everything I read seemed to indicate that was how to encrypt text, so I was, to least the least a little confused.

    Okay, so I just tried going to the textedit drop down menu after selecting the text --> services, and still nothing PGP related is coming up. I then went to "service preferences" in textedit to see if perhaps something happened related to that, but all PGP related things are checked. So, something strange is definitely going on here.

    I attached some screen captures so you can see what I mean.

  5. 6 Posted by Jim on 29 May, 2013 10:32 PM

    Jim's Avatar

    This is strange indeed. If you go to Service Preferences, under Keyboard Shortcuts and ensure that all OpenPGP options are checked, you should be able to encrypt any text within TextEdit by simply selecting all then right clicking Services>OpenPGP: Encrypt, or as stated, head up to the TextEdit dropdown and choose Services for the same options. I'm using 10.7.5 and it functions flawlessly this way.

  6. 7 Posted by Sam on 30 May, 2013 03:31 AM

    Sam 's Avatar

    And that's it! Under service preferences, below the first several selections, there are more PGP options. I just didn't scroll down far enough (I feel your pain IT people).

    Sweet, thanks for sticking with me y'all. Hope others find this helpful too.

  7. Support Staff 8 Posted by Steve on 30 May, 2013 01:42 PM

    Steve's Avatar

    Hehe, Sam, that's why in the tutorial we try to point out that there are two sections that need to be activated. Maybe we should make this more clearer?

    http://support.gpgtools.org/kb/faq-gpgservices/how-do-i-activate-th...

    But very glad this is now working as expected. And thank you for promptly updating the discussion.

    I'm closing this. Feel free to open a new discussion should you run into further issues.

    Best, steve

  8. Steve closed this discussion on 30 May, 2013 01:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac